It is currently Fri 15. Nov 2019 20:02:01

All times are UTC + 1 hour





Post new topic Reply to topic  [ 4 posts ] 
  Print view Previous topic | Next topic 
Author Message
PostPosted: Sat 06. Jul 2019 3:08:03 
Offline

Joined: Sat 04. May 2019 17:14:54
Posts: 38
I'm running Horus X10S OpenTX 2.2.3, FrSky XSR receiver, µSpirit 2.6.1, MacOS 10.13.6 Oxy 2.

The failsafe feature of the Spirit software does not seem to be working for me. Here's what I'm trying.

With my transmitter on and working, I go to General > Channels and set my transmitter stick and switches to my desired failsafe positions. Then I click Set Failsafe and get the message that "Failsafe values were successfully configured." I click OK, then close the Receiver mapping window, then I do CMD+S to save (I'm on a Mac).

Now if I physically unplug my XSR receiver from the Oxy 2, my swash plate goes nearly full positive, which was not my failsafe settings. Even if I set my failsafe setting to full negative collective with a bit of aileron or elevator, the swash plate seems to do the same thing each time.

And it doesn't matter if after doing CMD+S I then first unplug the battery (hoping to really save the failsafe).

Any ideas on how I can fix this?

Image

Image

Image

Image

_________________
Find me on HeliFreak, username Xoexoe


Top
 Profile  
 
PostPosted: Sat 06. Jul 2019 3:28:36 
Offline

Joined: Sat 04. May 2019 17:14:54
Posts: 38
Oh, I do have a second uSpirit that is running Spektrum TX/RX. I can see if there’s an issue on that too.

_________________
Find me on HeliFreak, username Xoexoe


Top
 Profile  
 
 Post subject: FOUND THE ISSUE: BUG!
PostPosted: Sat 06. Jul 2019 8:49:17 
Offline

Joined: Sat 04. May 2019 17:14:54
Posts: 38
Alright, I did a bunch of troubleshooting, and I believe I have found a bug!

I don't know if it is an S.Bus issue or a general bug. Okay, here it is.

If you take a look at my original pictures, you'll see that I had bank (channel 7) unassigned and I had rescue assigned to channel 8. With those settings, the Diagnosis tab was showing that Rescue was being enabled during failsafe, even though I had not enabled rescue during Set Failsafe. This is the reason that my collective pitch went to max as I posted in post #1.

Now, if I do assign bank to channel 7, the issue goes away; failsafe behaves as it should. Similarly, if I completely disable Rescue from channel 8 but leave my bank (channel 7) unassigned, then the issue goes away too.

So it seems to be a bug that Rescue is automatically enabled during Failsafe if both (1) Bank is unassigned and channel 7 is not used, and (2) Rescue is dedicated and assigned to channel 8.

_________________
Find me on HeliFreak, username Xoexoe


Top
 Profile  
 
PostPosted: Mon 08. Jul 2019 10:55:21 
Offline
Site Admin

Joined: Mon 29. Apr 2013 16:06:44
Posts: 9023
Hello,

thank you for the message.

You are right that the Rescue is engaged, but this is because Failsafe is supported for the first 7 channels.

Our upcoming firmware has Failsafe support for all channels so it should be enough to wait few days for new release.

_________________
Spirit System developer


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
skymiles_red v1.0.1 designed by Team -Programming forum-سيارات للبيع .