It is currently Mon 18. Feb 2019 5:26:13

All times are UTC + 1 hour





Post new topic Reply to topic  [ 3 posts ] 
  Print view Previous topic | Next topic 
Author Message
PostPosted: Thu 14. Feb 2019 8:43:21 
Offline

Joined: Tue 07. Aug 2018 11:18:36
Posts: 15
Hello,

I have a problem with my Spirit Pro settings.

The unit is installed in a Henseleit TDF (12s) and it shows a disturbing behaviour when the heli is in forward flight.
Everytime I give positive pitch input the nose goes up. This happens also if the heli is turned against the wind.
The faster the heli flies (or the stronger the wind is) the more the nose goes up with pitch input.
Because of this speed flying is very difficult because I need constantly nick input to keep the nose aligned.

If the heli stands still in the air and there is no wind the nose is complete stable, even with pitch pumps.

The rotor speed is approximately 1.250 rpm, the heli is balanced perfectly and the swash plate is even the whole way from max negative pitch to max positive pitch. The 6 degree geometry was set to 4.5.

I attached my Setting file and I hope you can tell me which Parameters I have to use to correct this.

Thank you very much,
Thomas


Attachments:
File comment: Spirit Settings
2019-01-12_Settings.4ds [255 Bytes]
Downloaded 35 times
Top
 Profile  
 
PostPosted: Thu 14. Feb 2019 14:11:03 
Offline
Site Admin

Joined: Mon 29. Apr 2013 16:06:44
Posts: 8494
Hello,

please make sure that when Servos/Subtrim (tuning) is ticked the servos are at the center position. At the same time swashplate is at the center position.
And at the same time there is 0° between main blades.

You might try to decrease Geometry 6° value little bit.

Alternatively please check vibration level with Spectrum Analysis - without blades. If there are extremely high vibrations then it could cause unexpected behavior and imprecision.

_________________
Spirit System developer


Top
 Profile  
 
PostPosted: Thu 14. Feb 2019 14:35:24 
Offline

Joined: Tue 07. Aug 2018 11:18:36
Posts: 15
ZeXx86 wrote:
Hello,

please make sure that when Servos/Subtrim (tuning) is ticked the servos are at the center position. At the same time swashplate is at the center position.
And at the same time there is 0° between main blades.

You might try to decrease Geometry 6° value little bit.

Alternatively please check vibration level with Spectrum Analysis - without blades. If there are extremely high vibrations then it could cause unexpected behavior and imprecision.


Hello!

Thank you for your answer!

During the build I checked that the center position is correct with my soko heli tool when Tuning is ticked.
I'm sure this can be excluded as a source for my Problem, but I'll check again.
The TDF is my seventh heli I've built so I think i'm experienced in heli set-up. But it's my first Spirit so perhaps I did something wrong.

I'll try decreasing the Geometry 6° as you suggest and check the vibration levels.
I'll report back next week if the problem still occurs.

Perhaps I should add that the rescue-function works without problems even at the end of an flight.

Bye,
Thomas


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
skymiles_red v1.0.1 designed by Team -Programming forum-سيارات للبيع .