It is currently Sun 23. Sep 2018 19:13:39

All times are UTC + 1 hour





Post new topic Reply to topic  [ 10 posts ] 
  Print view Previous topic | Next topic 
Author Message
PostPosted: Thu 13. Sep 2018 12:44:31 
Offline

Joined: Thu 13. Sep 2018 12:34:03
Posts: 6
I also posted this over on Helifreak, but I thought better to come to where the experts actually live...

Well, I had a crash on the mechanics that are going in my Mi24 scale fuselage. Trying to figure out what went wrong, and hoping for everyone's thoughts.

What happened:
Lifted off, established a low hover. Climbed to high hover (5-7' high, approx 25-30' from me). Did some tail rotor (pedal) turns. Made a further tail rotor turn so the helicopter is pointing off to my left in front of me, and transitioned to medium forward flight, climbing to about 10' AGL. Total air time on this flight is about 1:45 or so.

As the helicopter passed off to my left (approx 35-40' downrange), I notice that it was still in a slight-left hand bank. Tried to correct it. All controls completely locked out. Helicopter continued in that frozen attitude until it contacted a Spruce tree approximately 75-80' away. Took about 10-15 seconds to cover that distance (so not flying fast).

I originally though I'd had a radio lockout, but on examining the telemetry logs, the damage to the helicopter and the audio of a Go Pro sitting next to me, I don't think so. My Mezon 95 does NOT run through the Spirit Pro, it goes into the REX 12 rx, and there are indications that my shutting down the motor about 0.5-0.75 seconds before impact worked as best as it could. In the Jeti logs, I can see the motor amps dropping rapidly to 0 about 0.5-0.75 secs before the impact. The antenna signal, packet quality and avionics voltage are all fine until they end when the avionics battery is ejected in the impact.

Looking at the Spirit Pro log, I see a "Main Loop Hang Occurred" message about 10 seconds before a second "Main Loop Hang Occurred" message, which is accompanied by a "Power Voltage is Low" alarm - which, I expect, is the avionics battery being ejected.

Only 2 changes have occurred since the last successful flight of this helicopter:
1) I switched from 85mm swept plastic tail blades to 92 mm square tip carbon blades.
2) I updated my Spirit Pro from 2.43 (or 2.42, whatever) to 2.51 (directly, I didn't stop at 2.50)
(I did update to the newest Spirit.bin in the Jeti as well).

Helicopter Specs:
Audacity Pantera (FRP frame)
Scorpion HKIII 4035 330Kv - with clutch. Main NR is 1240rpm
Jeti Mezon 95 freewheel ESC with telemetry
Century Diamond 5 blade head with Funkey 600 x 43mm semi-symetric blades
Raised Triple blade tail using mix of MD & Minikopter parts, belt driven
2x 6S (12S) Hyperion HV 4400mah batteries
Western Digital Hercules BEC @ 7.4v from 3S Lipo avionics battery
Jeti REX12 reciever (Fw 1.01) in JetiEX/UDI mode to
Spirit Pro FBL, Fw 2.51
Jeti DS16 transmitter.

I'm adding the Jeti telemetry log, as well as the Spirit log here to help with diagnostics.

After updating the firmware - I did go through and confirm all Spirit settings and control movements were correct - remember, the helicopter was under complete control at the start of the flight.

My deepest thanks for any help you can provide. I've spoke with James at Esprit Tech on the Jeti side of things, and while we came up with some ideas, the cause of the lockup, and what locked up, is unknown.

I want to make sure that whatever caused is never returns! Crashes happen, it sucks, but that's the way it is.

cheers & thanks,
ed

BTW - I've changed the *.log extension on the Jeti Log to .txt so I can attach it.


Attachments:
Boris Mi24 Crash Log.txt [111.4 KiB]
Downloaded 30 times
spirit-log-2018-09-12-125955.pdf [75.33 KiB]
Downloaded 33 times
Top
 Profile  
 
PostPosted: Fri 14. Sep 2018 10:19:43 
Offline
Site Admin

Joined: Mon 29. Apr 2013 16:06:44
Posts: 7973
Hello,

that is very sad.. Thank you very much for all the details.
I believe we will find the issue and all will be OK.

Your details helped a lot.

From the log it look like something wrong happened to unit. This unfortunately could result in control lock out. It was not due to antenna signal.
There are only few possible issues that could cause this Main loop hang event.

1. Static discharge - is the model equipped with a belt?
2. Due to increased vibration level from bigger tail blades some connection of the PCB broken - so called cold joint emerged. This is quite uncommon but is possible.

My question is how long the model was flying previously? If it was flying for at least some weeks, months? Did you changed anything in the configuration?

_________________
Spirit System developer


Top
 Profile  
 
PostPosted: Fri 14. Sep 2018 12:38:05 
Offline

Joined: Thu 13. Sep 2018 12:34:03
Posts: 6
Hi Tomas;

Yes, not the outcome I'd desire! But... helicopters do crash, if not comfortable with that, probably shouldn't be in this hobby. My main concern is not to blame, not to yell, but to figure it out so that it doesn't happen again - that's what flight testing is about.

So to your questions:

1) Yes, the Pantera uses a tail belt drive system, in this case a very long (1800mm, 1000T S3M) belt to an elevated tail rotor system. I will be honest - I have another Pantera that flies pod and boom, and static has been a issue before on that one. Which is why this one has liberal amounts of silicon / teflon spay on the tail belt, that is re-applied every 2 flights.

2) The helicopter only has 7 flights (including the accident one) on it. So he's kinda a baby! IF you look at the SVibes level (in Jeti telemetry), you will see that the vibration level is quite low. The blades are only 7mm longer. When I lifted off yesterday, he seemed quite smooth in the air at the beginning.

3) No change in the Spirit configuration apart from updating to Fw 2.5.1. It was a good Fw update, no interruptions, no glitches, triple checked the programming and control surface movements after the Fw update.

When I get home today, I will add my Spirit settings file - and a "good" log file from a previous flight, in case that helps.

Thank you so much for you support - it is appreciated! We'll figure this out.
(Well, you will... I'm just the dumb pilot - but I'll give you all the data you need :D )

Cheers,

ed


Top
 Profile  
 
PostPosted: Sat 15. Sep 2018 6:10:14 
Offline

Joined: Thu 13. Sep 2018 12:34:03
Posts: 6
Hi Tomas;

As promised, I've attached my Spirit settings, and the Jeti log from the previous flight of Boris (my Mi-24's name - doesn't everyone give their helicopters names?)
Attachment:
Boris.jpg
Boris.jpg [ 458.6 KiB | Viewed 198 times ]

When he's all finished....

cheers,
ed


Attachments:
Boris Mi24 Good Log.log [830.38 KiB]
Downloaded 2 times
Boris Sept 11 2018.4ds [255 Bytes]
Downloaded 3 times
Top
 Profile  
 
PostPosted: Sat 15. Sep 2018 6:45:43 
Offline

Joined: Wed 09. Dec 2015 22:19:26
Posts: 6
I am guessing static, my pantera when I had an electric one I could hold a ground cable 1-1.5cm from the tail belt (in the opening on the side of the frame) and see the "lightning" from the belt to the grounded cable.

Fun to look at, not so fun to get into the electronics.


Top
 Profile  
 
PostPosted: Sun 16. Sep 2018 11:57:03 
Online
User avatar

Joined: Tue 21. Aug 2018 13:05:23
Posts: 15
maybe you can fix somewhere near the belt a small piece of copper mesh
connected to the ground of helicopter so the mesh will pick the static and discharge it
before to much charge will build up and generate a spark

Image


Top
 Profile  
 
PostPosted: Sun 16. Sep 2018 21:34:59 
Offline
Site Admin

Joined: Mon 29. Apr 2013 16:06:44
Posts: 7973
Thank you for the files.

The best to determine where the issue actually is, is to be able to replicate the problem.
Then you can later easily find if a solution helped or not without guessing.

I recommend to just spin up the motor/model without main blades as long as possible.
And then check all the logs if there is some strange message and possibly if you can see some bad servo movements during running.

If it is static then I recommend to mount all electronic, especially receiver as far from the boom as possible.

The model looks really awesome so it would be really sad to see it damaged.

_________________
Spirit System developer


Top
 Profile  
 
PostPosted: Mon 17. Sep 2018 22:49:29 
Offline

Joined: Thu 13. Sep 2018 12:34:03
Posts: 6
Hi Tomas;

Will do, I need to run down the batteries to storage anyway.

I'm going to try it as-is, without any static precautions, and see if we can get a "hit". Maybe shoot video as well.
Won't be tonight, will try to do tomorrow. I'll have to make a ground run tie-down rig.

As a question - I have several Jeti AddCap 10AS http://shop.jetiusa.com/Jeti-Receiver-Voltage-Protector-AddCap-10AS-p/jeti-ac-10as.htm on the way - basically a capacitor to handle voltage spikes. Would it be okay to plug one of them into a free port on the Spirit to help protect it?

Will also be wire grounding tail boom to either motor plate or avionics / receiver battery ground and adding ferrite rings to ESC->Rx line, BEC->Rx line, and possibly Rx->Spirit line as well.


Top
 Profile  
 
PostPosted: Thu 20. Sep 2018 1:38:30 
Offline

Joined: Thu 13. Sep 2018 12:34:03
Posts: 6
Hi Tomas;

Did a very long ground run today (20+ minutes). No freezes or lockups in the control were visible (I was regularly stirring the sticks). Tried it with and without Stabilization on (the crash occurred with Stabilization OFF). Full control at all times.

I've attached the Jeti Log as well as the Spirit Log. Interestingly, the Spirit shows a couple of Receiver signal losses; the Jeti shows antenna RSSI at 9/9 all the time on both antennas, as well as a packet Quality of 94-100% through the run.

The full ground system (to Avionics battery Neg) was not in place for this test.

Hopefully the logs will tell you more than they tell me!

cheers,

Ed


Attachments:
Boris Ground Run Log.zip [275.05 KiB]
Downloaded 2 times
spirit-log-2018-09-19-201218.pdf [73.79 KiB]
Downloaded 4 times
Top
 Profile  
 
PostPosted: Sun 23. Sep 2018 10:42:37 
Offline
Site Admin

Joined: Mon 29. Apr 2013 16:06:44
Posts: 7973
Hi,

if you can see receiver signal lost events then with very high certainty there are big issues with static discharges.
This mean that connection is lost for over 1s when this happened. In flight this could be even longer and problem could arise.
So data between receiver and Spirit are simply missing. Are you using EX Bus connection, right?

Yes, a capacitor can be added to a free port (except SYS and ELE/PIT/AIL). Or it can be in the receiver. This is very helpful.

But it is important that in any case there will be no receiver signal lost event.
I recommend to ground it as much as possible and to feed all cables far from the belt.

_________________
Spirit System developer


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
skymiles_red v1.0.1 designed by Team -Programming forum-سيارات للبيع .