Spirit System

Deadband too big
Page 1 of 1

Author:  Cyber [ Sun 27. Oct 2019 17:18:08 ]
Post subject:  Deadband too big

I fly more than 13 years flybarless Helikopters with vbar and Graupner GR18.
Now I have a big Problem After the Maiden Flights with the Spirit.
The deadband of 4 is still to high. It flies digital. Sometimes the Spirit donˋt recognize my small Inputs. Need help for a lower deadband, please.

Greetz Daniel

Author:  ZeXx86 [ Wed 30. Oct 2019 9:05:07 ]
Post subject:  Re: Deadband too big


V-Bar is using much bigger deadband so I think the problem is not there.
The value of 4 is minimum because stick readings in todays radios, even with hall sensors are of this precision. Lowering will not allow more precise movements since with this value you can make already very precise movements.

Maybe you are using Bank Switching and this value is configured only for one Bank.

V-Bar has extremely high Expo configured by default which mean you could think it is normal, but the stick movement is not linear at all and you are probably used to it.
So you might need to set similar expo in your radio.

Author:  Cyber [ Sun 01. Dec 2019 0:16:16 ]
Post subject:  Re: Deadband too big

After some flights I still must say that I feel a deadband. Especially in big slow funnels with very little rudder input there is often no yaw rate, although I give little stick input.
And my radio sticks are well calibrated.
Does the new software maybe allow a lower possibly deadband, or can you send me a test software, please?

Author:  ZeXx86 [ Tue 03. Dec 2019 9:11:49 ]
Post subject:  Re: Deadband too big

The movements around center should be very smooth and you should be able to perform super slow pirouettes.
Are you using a Bank Switching?

If yes, then this parameter can be configured for each bank differently. Maybe the problem is there.

Moreover the settings should work always in the same way, not just sometimes.

You should be able to see servo movement at the bench. Please try to move with the stick and observe if movement is really smooth and you can change yaw slowly.

Author:  Cyber [ Sun 08. Dec 2019 17:30:11 ]
Post subject:  Re: Deadband too big


yes, behind the deadband the pirouettes are very slow and the yaw rate is stable.
But as I already mentioned unfortunately behind the threshold.
I tested it on the table:
The rudder servo is starting to move when the channel Input is above +3% or -3%.
This is also the value where the input value is displayed in bold in spirit Settings/diagnostics, so it seems to be the deadband.

Bank switching is disabled and no channel is assigned for it.

My Graupner radio and other Graupner radios are very precise with 0% channel Input at the center of the sticks, therefore the GR-18 flybarless Software allows from default a much lower deadband and the servos moves already at 1% stick input.

Please send me a Software which allow a deadband down to 1% stick Input. Thank you in advance.

Author:  ZeXx86 [ Tue 05. May 2020 12:19:57 ]
Post subject:  Re: Deadband too big


with upcoming firmware release deadband range was changed. So it will be better for you.

Page 1 of 1 All times are UTC + 1 hour
Powered by phpBB® Forum Software © phpBB Group