Spirit System
http://spirit-system.com/phpBB3/

FrSky OS and lua Support - Spirit's luas didn't work
http://spirit-system.com/phpBB3/viewtopic.php?f=20&t=3149
Page 1 of 1

Author:  scvflyer [ Sun 10. Feb 2019 21:12:39 ]
Post subject:  FrSky OS and lua Support - Spirit's luas didn't work

hello serviceteam,
I use FrSky 12S with FrSky OS version 1.6. (this supports lua execution). Connection from RX to SpiritPro is done via S-BUS. Comming to different effects.
Start basic.lua - finish TX completely
start specia.lua -ends in message "NIL can't be returned" - after that nothing happend.
So no lua-setup possible.
To figure out if issue is at FrSky OS 1.6 or Spirit's lua-scripting - my question here.
In addition - Values from HW ESC 130 V4 are not recognized at my RX - that's why I tried to use lua support from TX getting sensor id.
BTW - there is an product servo channel changer - would that help ?
thanks in advance and br Siggi

Author:  ZeXx86 [ Sun 10. Feb 2019 22:43:37 ]
Post subject:  Re: FrSky OS and lua Support - Spirit's luas didn't work

Hello,

unfortunately the LUA scripts are not supported by Frsky OS. It is possible that in near future it will be compatible.
For running the scripts OpenTX is needed.

Author:  scvflyer [ Mon 11. Feb 2019 9:25:01 ]
Post subject:  Re: FrSky OS and lua Support - Spirit's luas didn't work

Hello serviceteam,
that's what I expected - because your documentation is clear "integration to openTX". Just hoped that compability is given.
What did you think - when will your integration to FrSky OS available?
And could it help using service channel changer to make ESC Telemetry available to FRSky OS ?
thanks and br siggi

Author:  ZeXx86 [ Mon 11. Feb 2019 20:19:01 ]
Post subject:  Re: FrSky OS and lua Support - Spirit's luas didn't work

Hello,

this is dependent on FrSky, but we will check the status.
You can already utilize telemetry with the same connection that is used for OpenTX.

Author:  scvflyer [ Mon 11. Feb 2019 21:41:26 ]
Post subject:  Re: FrSky OS and lua Support - Spirit's luas didn't work

Hello,
yes - I did as advised at documentation, but telemetry values from Spirit are not recognized.
Could be that FrSky OS expect special Sensor ID for that values (because it can't be adjusted at TX)? I only know that FrSky OS scans for connected sensors. I'm trying to get that information from FrSky Support.
But this question brings me to additional questions.
Which Sensor ID is set for that from spirit-pro?
Because there is no sensor id setup in your software - is it possible to set sensor id at spirit pro from out side - e.g. using "servo channel changer" or something else?
thanks and br siggi

Author:  ZeXx86 [ Wed 13. Feb 2019 11:50:36 ]
Post subject:  Re: FrSky OS and lua Support - Spirit's luas didn't work

Hello,

no, it should detect the sensors automatically. It is using normal sensor IDs that are available in the FrSky documentation.
So there is no reason to change them. There are few different Sensor IDs. For example 0x0400, 0x0500, 0x0600, 0x0b00, 0x0b30, 0x5120

Do you have something else connected at the S.PORT bus?

Author:  scvflyer [ Thu 14. Feb 2019 8:00:14 ]
Post subject:  Re: FrSky OS and lua Support - Spirit's luas didn't work

Hello,
I tried both - in combination with other sensors and without any additional sensor. Both time same effect.
But I found here - in spirit forum - a topic regarding to "Using Receiver RX8R and no telemetry". (Unfortunally User changed his TX to OpenTX). I'm using an RX8R as well - and FrSkyOS.
And as I understood - Case is still under investigation from your side and /or FrSky as well.
Whatever - I will check if newer firmware available for my RX8R. Will give a feedback here as soon as possible
Thanks and br siggi

Page 1 of 1 All times are UTC + 1 hour
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/