It is currently Thu 20. Jun 2019 11:59:30

All times are UTC + 1 hour





Post new topic Reply to topic  [ 6 posts ] 
  Print view Previous topic | Next topic 
Author Message
PostPosted: Sun 17. Jun 2018 16:55:58 
Offline

Joined: Sun 04. Feb 2018 15:31:41
Posts: 20
Hi,

My Spirit Pro has been flying very nicely in my Diabolo 700 and I'm very happy with it.
However, I'm trying to solve an odd behaviour that I've never seen before on any other helicopters: on the bench, all 3 cyclic servos sound and feel very 'notchy' or 'rough' when i move the collective up and down, but ONLY with collective. With cyclic movements, they are all very smooth. The behaviour is always the same whether I do quick or slow stick movements. The tail servo also is notchy.
Is this normal? Is there a setting that I can use to fix this?
In flight, there are no observable problems.
My servos are Promodeler S74245BLHV for cyclic and MKS HBL980 for the tail. Servo frequencies all set within the servo specifications.
Thanks
Chris


Top
 Profile  
 
PostPosted: Sun 17. Jun 2018 17:01:24 
Offline
Site Admin

Joined: Mon 29. Apr 2013 16:06:44
Posts: 8738
Hi,

this could be caused by too slow refresh rate from your receiver.
Spirit unit is transmitting the data few times faster than an usual receiver does.
So you can see how it is really transferred with a fast servos.

If your radio support faster transmission, then it can be improved significantly.

Usually with 50Hz/20ms you will feel such behavior. With 100Hz is it much better. But in both cases it is normal.

_________________
Spirit System developer


Top
 Profile  
 
PostPosted: Sun 17. Jun 2018 19:21:35 
Offline

Joined: Sun 04. Feb 2018 15:31:41
Posts: 20
Okay, I will check to see if I can change the receiver/tx refresh rate. I'm using Spektrum DX8 G2 along with Spektrum sats.
Thanks very much for the explanation! So if I remains notchy, it's not a problem for the servos?
Thank you
Chris


Top
 Profile  
 
PostPosted: Mon 18. Jun 2018 7:19:24 
Offline
Site Admin

Joined: Mon 29. Apr 2013 16:06:44
Posts: 8738
No, it is not a problem.

You can just verify if your connection is running at 11ms. This depend on how you have bound the satellites.

_________________
Spirit System developer


Top
 Profile  
 
PostPosted: Mon 18. Jun 2018 11:59:32 
Offline

Joined: Sun 04. Feb 2018 15:31:41
Posts: 20
The default frame rate in the DX8 is 22ms. I changed it to 11 and rebinded an all servos are much smoother now!
Thank you for your help! ;)
Chris


Top
 Profile  
 
PostPosted: Mon 18. Jun 2018 13:36:50 
Offline
Site Admin

Joined: Mon 29. Apr 2013 16:06:44
Posts: 8738
Good job. Thank you for the message.

_________________
Spirit System developer


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: Bing [Bot] and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
skymiles_red v1.0.1 designed by Team -Programming forum-سيارات للبيع .